What’s Vulnerable › Vulnerabilities
CVE-2024-34435: WordPress Aiomatic plugin <= 1.9.3 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in CodeRevolution Aiomatic.This issue affects Aiomatic: from n/a through 1.9.3.
Affected products
- CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit: before 1.9.4 — fixed in 1.9.4
How to fix
Upgrade to a fixed version: CodeRevolution Aiomatic - Automatic AI Content Writer & Editor, GPT-3 & GPT-4, ChatGPT ChatBot & AI Toolkit 1.9.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/aiomatic-automatic-ai-content-writer/wordpress-aiomatic-plugin-1-9-3-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/aiomatic-automatic-ai-content-writer/wordpress-aiomatic-plugin-1-9-3-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-34435 or the next vulnerability affects your stack