What’s Vulnerable › Vulnerabilities
CVE-2024-34470
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-06 · updated 2026-06-17
- Weakness: CWE-29
Description
An issue was discovered in HSC Mailinspector 5.2.17-3 through v.5.2.18. An Unauthenticated Path Traversal vulnerability exists in the /public/loader.php file. The path parameter does not properly filter whether the file and directory passed are part of the webroot, allowing an attacker to read arbitrary files on the server.
Affected products
- Hsclabs Mailinspector: from 5.2.17-3 before 5.2.19 — fixed in 5.2.19
How to fix
Upgrade to a fixed version: Hsclabs Mailinspector 5.2.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34470 or the next vulnerability affects your stack