What’s Vulnerable › Vulnerabilities
CVE-2024-34476
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-05 · updated 2026-06-17
- Weakness: CWE-805
Description
Open5GS before 2.7.1 is vulnerable to a reachable assertion that can cause an AMF crash via NAS messages from a UE: ogs_nas_encrypt in lib/nas/common/security.c for pkbuf->len.
Affected products
- Open5GS: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Open5GS 2.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/open5gs/open5gs/compare/v2.7.0...v2.7.1
- https://github.com/open5gs/open5gs/pull/3122
- https://github.com/open5gs/open5gs/compare/v2.7.0...v2.7.1
- https://github.com/open5gs/open5gs/pull/3122
Get alerted when CVE-2024-34476 or the next vulnerability affects your stack