What’s Vulnerable › Vulnerabilities
CVE-2024-34502
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-05 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in WikibaseLexeme in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. Loading Special:MergeLexemes will (attempt to) make an edit that merges the from-id to the to-id, even if the request was not a POST request, and even if it does not contain an edit token.
Affected products
- Fedoraproject Fedora: 40
- Wikimedia Foundation MediaWiki: before 1.39.6; from 1.40.0 before 1.40.2; from 1.41.0 before 1.41.1 — fixed in 1.39.6, 1.40.2, 1.41.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.6, 1.40.2, 1.41.1. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseLexeme/+/1013359
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T357101
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseLexeme/+/1013359
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T357101
Get alerted when CVE-2024-34502 or the next vulnerability affects your stack