What’s Vulnerable › Vulnerabilities
CVE-2024-34506
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-05 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in includes/specials/SpecialMovePage.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. If a user with the necessary rights to move the page opens Special:MovePage for a page with tens of thousands of subpages, then the page will exceed the maximum request time, leading to a denial of service.
Affected products
- Fedoraproject Fedora: 40
- Wikimedia Foundation MediaWiki: before 1.39.7; from 1.40.0 before 1.40.3; from 1.41.0 before 1.41.1 — fixed in 1.39.7, 1.40.3, 1.41.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.7, 1.40.3, 1.41.1. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T357760
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T357760
Get alerted when CVE-2024-34506 or the next vulnerability affects your stack