What’s Vulnerable › Vulnerabilities
CVE-2024-34507
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-05 · updated 2026-06-17
- Weakness: CWE-80
Description
An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. XSS can occur because of mishandling of the 0x1b character, as demonstrated by Special:RecentChanges#%1b0000000.
Affected products
- Fedoraproject Fedora: 40
- Wikimedia Foundation MediaWiki: before 1.39.7; from 1.40.0 before 1.40.3; from 1.41.0 before 1.41.1 — fixed in 1.39.7, 1.40.3, 1.41.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.39.7, 1.40.3, 1.41.1. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T355538
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/
- https://phabricator.wikimedia.org/T355538
Get alerted when CVE-2024-34507 or the next vulnerability affects your stack