What’s Vulnerable › Vulnerabilities
CVE-2024-34508
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-05 · updated 2026-06-17
- Weakness: CWE-476
Description
dcmnet in DCMTK before 3.6.9 has a segmentation fault via an invalid DIMSE message.
Affected products
- Debian Linux: 10.0
- OFFIS DCMTK: before 3.6.9 — fixed in 3.6.9
How to fix
Upgrade to a fixed version: OFFIS DCMTK 3.6.9. Check the vendor advisory for mitigations.
References
- https://github.com/DCMTK/dcmtk/commit/c78e434c0c5f9d932874f0b17a8b4ce305ca01f5
- https://lists.debian.org/debian-lts-announce/2024/06/msg00022.html
- https://support.dcmtk.org/redmine/issues/1114
- https://github.com/DCMTK/dcmtk/commit/c78e434c0c5f9d932874f0b17a8b4ce305ca01f5
- https://lists.debian.org/debian-lts-announce/2024/06/msg00022.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00032.html
- https://support.dcmtk.org/redmine/issues/1114
Get alerted when CVE-2024-34508 or the next vulnerability affects your stack