What’s Vulnerable › Vulnerabilities

CVE-2024-34517

Description

The Cypher component in Neo4j 5.0.0 through 5.18 mishandles IMMUTABLE privileges in some situations where an attacker already has admin access.

Affected products

How to fix

Upgrade to a fixed version: Neo4j 5.19.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-34517 or the next vulnerability affects your stack