What’s Vulnerable › Vulnerabilities
CVE-2024-34532
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-06 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection vulnerability in Yvan Dotet PostgreSQL Query Deluxe module (aka query_deluxe) 17.x before 17.0.0.4 allows a remote attacker to gain privileges via the query parameter to models/querydeluxe.py:QueryDeluxe::get_result_from_query.
Affected products
- Query Deluxe: from 17.0 before 17.0.0.4 — fixed in 17.0.0.4
How to fix
Upgrade to a fixed version: Query Deluxe 17.0.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/luvsn/OdZoo/tree/main/exploits/query_deluxe
- https://github.com/luvsn/OdZoo/tree/main/exploits/query_deluxe
Get alerted when CVE-2024-34532 or the next vulnerability affects your stack