What’s Vulnerable › Vulnerabilities
CVE-2024-34566: WordPress Content Blocks (Custom Post Widget) plugin <= 3.3.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Johan van der Wijk Content Blocks (Custom Post Widget) allows Stored XSS.This issue affects Content Blocks (Custom Post Widget): from n/a through 3.3.0.
Affected products
- vanderwijk Content Blocks (Custom Post Widget): before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: vanderwijk Content Blocks (Custom Post Widget) 3.3.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/custom-post-widget/wordpress-content-blocks-custom-post-widget-plugin-3-3-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/custom-post-widget/wordpress-content-blocks-custom-post-widget-plugin-3-3-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-34566 or the next vulnerability affects your stack