What’s Vulnerable › Vulnerabilities
CVE-2024-3470: Repository administrator can bypass organization's ruleset using deploy keys
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-19 · updated 2026-06-17
- Weakness: CWE-269
Description
An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use a deploy key pertaining to an organization to bypass an organization ruleset. An attacker would require access to a valid deploy key for a repository in the organization as well as repository administrator access. This vulnerability affected versions of GitHub Enterprise Server 3.11 to 3.12 and was fixed in versions 3.11.8 and 3.12.2. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.11.0 before 3.11.8; from 3.12.0 before 3.12.2 — fixed in 3.11.8, 3.12.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.11.8, 3.12.2. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.8
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.2
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.8
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.2
Get alerted when CVE-2024-3470 or the next vulnerability affects your stack