What’s Vulnerable › Vulnerabilities
CVE-2024-34711: GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-200
Description
GeoServer is an open source server that allows users to share and edit geospatial data. An improper URI validation vulnerability exists that enables an unauthorized attacker to perform XML External Entities (XEE) attack, then send GET request to any HTTP server. By default, GeoServer use PreventLocalEntityResolver class from GeoTools to filter out malicious URIs in XML entities before resolving them. The URI must match the regex (?i)(jar:file|http|vfs)[^?#;]*\\.xsd. But the regex leaves a chance for attackers to request to any HTTP server or limited file. Attacker can abuse this to scan internal networks and gain information about them then exploit further. GeoServer 2.25.0 and greater default to the use of ENTITY_RESOLUTION_ALLOWLIST and does not require you to provide a system property.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.25.0 — fixed in 2.25.0
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.25.0. Check the vendor advisory for mitigations.
References
- https://docs.geoserver.org/latest/en/user/production/config.html#production-config-external-entities
- https://github.com/geoserver/geoserver/security/advisories/GHSA-mc43-4fqr-c965
Get alerted when CVE-2024-34711 or the next vulnerability affects your stack