What’s Vulnerable › Vulnerabilities
CVE-2024-34713: sshproxy vulnerable to SSH option injection
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-77
Description
sshproxy is used on a gateway to transparently proxy a user SSH connection on the gateway to an internal host via SSH. Prior to version 1.6.3, any user authorized to connect to a ssh server using `sshproxy` can inject options to the `ssh` command executed by `sshproxy`. All versions of `sshproxy` are impacted. The problem is patched starting in version 1.6.3. The only workaround is to use the `force_command` option in `sshproxy.yaml`, but it's rarely relevant.
Affected products
- cea-hpc sshproxy: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: cea-hpc sshproxy 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/cea-hpc/sshproxy/commit/f7eabd05d5f0f951e160293692327cad9a7d9580
- https://github.com/cea-hpc/sshproxy/security/advisories/GHSA-jmqp-37m5-49wh
- https://github.com/cea-hpc/sshproxy/commit/f7eabd05d5f0f951e160293692327cad9a7d9580
- https://github.com/cea-hpc/sshproxy/security/advisories/GHSA-jmqp-37m5-49wh
Get alerted when CVE-2024-34713 or the next vulnerability affects your stack