What’s Vulnerable › Vulnerabilities
CVE-2024-34757: WordPress Borderless plugin <= 1.7.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Visualmodo Borderless borderless allows DOM-Based XSS.This issue affects Borderless: from n/a through <= 1.7.3.
Affected products
- visualmodo Borderless – Addons and Templates for Elementor: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: visualmodo Borderless – Addons and Templates for Elementor 1.5.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/borderless/vulnerability/wordpress-borderless-widgets-elements-templates-and-toolkit-for-elementor-gutenberg-plugin-1-5-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/borderless/wordpress-borderless-widgets-elements-templates-and-toolkit-for-elementor-gutenberg-plugin-1-5-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-34757 or the next vulnerability affects your stack