What’s Vulnerable › Vulnerabilities
CVE-2024-34759: WordPress Picture Gallery plugin <= 1.5.11 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in VideoWhisper Picture Gallery allows Stored XSS.This issue affects Picture Gallery: from n/a through 1.5.11.
Affected products
- videowhisper Picture Gallery: before 1.5.12 — fixed in 1.5.12
How to fix
Upgrade to a fixed version: videowhisper Picture Gallery 1.5.12. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/picture-gallery/wordpress-picture-gallery-plugin-1-5-11-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/picture-gallery/wordpress-picture-gallery-plugin-1-5-11-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-34759 or the next vulnerability affects your stack