What’s Vulnerable › Vulnerabilities
CVE-2024-34767: WordPress ShopLentor plugin <= 2.8.7 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in HasThemes ShopLentor allows Stored XSS.This issue affects ShopLentor: from n/a through 2.8.7.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.8.8 — fixed in 2.8.8
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.8.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woolentor-addons/wordpress-shoplentor-plugin-2-8-7-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woolentor-addons/wordpress-shoplentor-plugin-2-8-7-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-34767 or the next vulnerability affects your stack