What’s Vulnerable › Vulnerabilities
CVE-2024-34791: WordPress WPB Elementor Addons plugin <= 1.0.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in wpbean WPB Elementor Addons allows Stored XSS.This issue affects WPB Elementor Addons: from n/a through 1.0.9.
Affected products
- wpbean WPB Addons for Elementor – News Ticker, Timeline, Team & More Widgets: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: wpbean WPB Addons for Elementor – News Ticker, Timeline, Team & More Widgets 1.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wpb-elementor-addons/wordpress-wpb-elementor-addons-plugin-1-0-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wpb-elementor-addons/wordpress-wpb-elementor-addons-plugin-1-0-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-34791 or the next vulnerability affects your stack