What’s Vulnerable › Vulnerabilities
CVE-2024-34795: WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.
Affected products
- Tainacan: before 0.21.4 — fixed in 0.21.4
How to fix
Upgrade to a fixed version: Tainacan 0.21.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/tainacan/vulnerability/wordpress-tainacan-plugin-0-21-3-cross-site-scripting-xss-vulnerability-2?_s_id=cve
- https://patchstack.com/database/vulnerability/tainacan/wordpress-tainacan-plugin-0-21-3-cross-site-scripting-xss-vulnerability-2?_s_id=cve
Get alerted when CVE-2024-34795 or the next vulnerability affects your stack