What’s Vulnerable › Vulnerabilities
CVE-2024-34914
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-328
Description
php-censor v2.1.4 and fixed in v.2.1.5 was discovered to utilize a weak hashing algorithm for its remember_key value. This allows attackers to bruteforce to bruteforce the remember_key value to gain access to accounts that have checked "remember me" when logging in.
Affected products
- Php-Censor: from 2.1.4 before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: Php-Censor 2.1.5. Check the vendor advisory for mitigations.
References
- https://chmod744.super.site/redacted-vulnerability
- https://chmod744.super.site/redacted-vulnerability
Get alerted when CVE-2024-34914 or the next vulnerability affects your stack