What’s Vulnerable › Vulnerabilities
CVE-2024-34988
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in the module "Complete for Create a Quote in Frontend + Backend Pro" (askforaquotemodul) <= 1.0.51 from Buy Addons for PrestaShop allows attackers to view sensitive information and cause other impacts via methods `AskforaquotemodulcustomernewquoteModuleFrontController::run()`, `AskforaquotemoduladdproductnewquoteModuleFrontController::run()`, `AskforaquotemodulCouponcodeModuleFrontController::run()`, `AskforaquotemodulgetshippingcostModuleFrontController::run()`, `AskforaquotemodulgetstateModuleFrontController::run().`
Affected products
- PrestaShop Ask For A Quote: before 1.0.52 — fixed in 1.0.52
How to fix
Upgrade to a fixed version: PrestaShop Ask For A Quote 1.0.52. Check the vendor advisory for mitigations.
References
- https://security.friendsofpresta.org/modules/2024/06/20/askforaquotemodul.html
- https://security.friendsofpresta.org/modules/2024/06/20/askforaquotemodul.html
Get alerted when CVE-2024-34988 or the next vulnerability affects your stack