What’s Vulnerable › Vulnerabilities
CVE-2024-3500: ElementsKit Pro <= 3.6.0 - Authenticated (Contributor+) Local File Inclusion via Price Menu, Hotspot, and Advanced Toggle Widgets
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-98
Description
The ElementsKit Pro plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.6.0 via the Price Menu, Hotspot, and Advanced Toggle widgets. This makes it possible for authenticated attackers, with contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. CVE-2024-43996 is potentially a duplicate of this issue.
Affected products
- wpmet ElementsKit Pro: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: wpmet ElementsKit Pro 3.6.1. Check the vendor advisory for mitigations.
References
- https://account.wpmet.com/downloads/elementskit/?changelog=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c8ae0a47-cba5-468e-8d25-7b7176373b9c?source=cve
- https://account.wpmet.com/downloads/elementskit/?changelog=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c8ae0a47-cba5-468e-8d25-7b7176373b9c?source=cve
Get alerted when CVE-2024-3500 or the next vulnerability affects your stack