What’s Vulnerable › Vulnerabilities
CVE-2024-3501: Exposure of Sensitive Information in lunary-ai/lunary
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-922
Description
In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists due to the inclusion of single-use tokens in the responses of `GET /v1/users/me` and `GET /v1/users/me/org` API endpoints. These tokens, intended for sensitive operations such as password resets or account verification, are exposed to unauthorized actors, potentially allowing them to perform actions on behalf of the user. This issue was addressed in version 1.2.6, where the exposure of single-use tokens in user-facing queries was mitigated.
Affected products
- lunary-ai/lunary: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/17e95f6c99c7d5ac4ee5451c5857b97a12892c74
- https://huntr.com/bounties/8fdfdb9d-10bd-4f00-8004-d5baabc20c6e
Get alerted when CVE-2024-3501 or the next vulnerability affects your stack