What’s Vulnerable › Vulnerabilities
CVE-2024-3502: Exposure of Sensitive Information in lunary-ai/lunary
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-201
Description
In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists where account recovery hashes of users are inadvertently exposed to unauthorized actors. This issue occurs when authenticated users inspect responses from `GET /v1/users/me` and `GET /v1/users/me/org` endpoints. The exposed account recovery hashes, while not directly related to user passwords, represent sensitive information that should not be accessible to unauthorized parties. Exposing these hashes could potentially facilitate account recovery attacks or other malicious activities. The vulnerability was addressed in version 1.2.6.
Affected products
- lunary-ai/lunary: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/17e95f6c99c7d5ac4ee5451c5857b97a12892c74
- https://huntr.com/bounties/c2aff952-2dec-4538-8905-190c484aae94
Get alerted when CVE-2024-3502 or the next vulnerability affects your stack