What’s Vulnerable › Vulnerabilities
CVE-2024-3504: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-863
Description
An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.
Affected products
- lunary-ai/lunary: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/f7507f0949f6634f725ebb8da37c44f76542901f
- https://huntr.com/bounties/97958fe4-be21-4b63-966f-8337c72c8e28
- https://github.com/lunary-ai/lunary/commit/f7507f0949f6634f725ebb8da37c44f76542901f
- https://huntr.com/bounties/97958fe4-be21-4b63-966f-8337c72c8e28
Get alerted when CVE-2024-3504 or the next vulnerability affects your stack