What’s Vulnerable › Vulnerabilities
CVE-2024-3505: JFrog Self-Hosted Artifactory Proxy configuration accessible to low-privilege users
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-200
Description
JFrog Artifactory Self-Hosted versions below 7.77.3, are vulnerable to sensitive information disclosure whereby a low-privileged authenticated user can read the proxy configuration. This does not affect JFrog cloud deployments.
Affected products
- jfrog artifactory: before 7.77.3 — fixed in 7.77.3
How to fix
Upgrade to a fixed version: jfrog artifactory 7.77.3. Check the vendor advisory for mitigations.
References
- https://jfrog.com/help/r/jfrog-release-information/jfrog-security-advisories
- https://jfrog.com/help/r/jfrog-release-information/jfrog-security-advisories
Get alerted when CVE-2024-3505 or the next vulnerability affects your stack