What’s Vulnerable › Vulnerabilities
CVE-2024-35153: IBM WebSphere Application Server cross-site scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server 8.5 and 9.0 is vulnerable to cross-site scripting. This vulnerability allows a privileged user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 292640.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.26; from 9.0.0.0 before 9.0.5.21 — fixed in 8.5.5.26, 9.0.5.21
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.26, 9.0.5.21. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/292640
- https://www.ibm.com/support/pages/node/7158662
- https://exchange.xforce.ibmcloud.com/vulnerabilities/292640
- https://www.ibm.com/support/pages/node/7158662
Get alerted when CVE-2024-35153 or the next vulnerability affects your stack