What’s Vulnerable › Vulnerabilities
CVE-2024-35164: Apache Guacamole: Improper input validation of console codes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-129
Description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Guacamole: from 0.8.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Guacamole 1.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/sgs8lplbkrpvd3hrvcnnxh3028h4py70
- http://www.openwall.com/lists/oss-security/2025/07/01/2
Get alerted when CVE-2024-35164 or the next vulnerability affects your stack