What’s Vulnerable › Vulnerabilities
CVE-2024-35176: REXML contains a denial of service vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-400
Description
REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.
Affected products
- ruby rexml: before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: ruby rexml 3.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/rexml/commit/4325835f92f3f142ebd91a3fdba4e1f1ab7f1cfb
- https://github.com/ruby/rexml/security/advisories/GHSA-vg3r-rm7w-2xgh
- https://www.ruby-lang.org/en/news/2024/05/16/dos-rexml-cve-2024-35176
- https://github.com/ruby/rexml/commit/4325835f92f3f142ebd91a3fdba4e1f1ab7f1cfb
- https://github.com/ruby/rexml/security/advisories/GHSA-vg3r-rm7w-2xgh
- https://lists.debian.org/debian-lts-announce/2025/01/msg00011.html
- https://security.netapp.com/advisory/ntap-20250306-0001/
- https://www.ruby-lang.org/en/news/2024/05/16/dos-rexml-cve-2024-35176
Get alerted when CVE-2024-35176 or the next vulnerability affects your stack