What’s Vulnerable › Vulnerabilities
CVE-2024-35199: TorchServe gRPC Port Exposure
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-668
Description
TorchServe is a flexible and easy-to-use tool for serving and scaling PyTorch models in production. In affected versions the two gRPC ports 7070 and 7071, are not bound to [localhost](http://localhost/) by default, so when TorchServe is launched, these two interfaces are bound to all interfaces. Customers using PyTorch inference Deep Learning Containers (DLC) through Amazon SageMaker and EKS are not affected. This issue in TorchServe has been fixed in PR #3083. TorchServe release 0.11.0 includes the fix to address this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- pytorch serve: from 0.3.0 before 0.11.0 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: pytorch serve 0.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/pytorch/serve/pull/3083
- https://github.com/pytorch/serve/releases/tag/v0.11.0
- https://github.com/pytorch/serve/security/advisories/GHSA-hhpg-v63p-wp7w
- https://github.com/pytorch/serve/pull/3083
- https://github.com/pytorch/serve/releases/tag/v0.11.0
- https://github.com/pytorch/serve/security/advisories/GHSA-hhpg-v63p-wp7w
Get alerted when CVE-2024-35199 or the next vulnerability affects your stack