What’s Vulnerable › Vulnerabilities
CVE-2024-35202
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Bitcoin Core before 25.0 allows remote attackers to cause a denial of service (blocktxn message-handling assertion and node exit) by including transactions in a blocktxn message that are not committed to in a block's merkle root. FillBlock can be called twice for one PartiallyDownloadedBlock instance.
Affected products
- Bitcoin Core: before 25.0 — fixed in 25.0
How to fix
Upgrade to a fixed version: Bitcoin Core 25.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/10/08/disclose-blocktxn-crash/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://github.com/bitcoin/bitcoin/blob/master/doc/release-notes/release-notes-25.0.md
- https://github.com/bitcoin/bitcoin/pull/26898
- https://github.com/bitcoin/bitcoin/releases/tag/v25.0
Get alerted when CVE-2024-35202 or the next vulnerability affects your stack