What’s Vulnerable › Vulnerabilities

CVE-2024-35203

Description

Mahara before 22.10.6, 23.04.6, and 24.04.1 allows cross-site scripting (XSS) via a file, with JavaScript code as part of its name, that is uploaded via the Mahara filebrowser system.

Affected products

How to fix

Upgrade to a fixed version: mahara 22.10.6, 23.04.6, 24.04.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-35203 or the next vulnerability affects your stack