What’s Vulnerable › Vulnerabilities
CVE-2024-35230: Welcome and About GeoServer pages communicate version and revision information
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-16 · updated 2026-06-17
- Weakness: CWE-200
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- geoserver org.geoserver.extension:gs-db2: from 2.0.0 before 2.25.1 — fixed in 2.25.1
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.25.1. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/commit/74fdab745a5deff20ac99abca24d8695fe1a52f8
- https://github.com/geoserver/geoserver/commit/8cd1590a604a10875de67b04995f1952f631f920
- https://github.com/geoserver/geoserver/security/advisories/GHSA-6pfc-w86r-54q6
- https://github.com/geoserver/geoserver/security/advisories/GHSA-6pfc-w86r-54q6
Get alerted when CVE-2024-35230 or the next vulnerability affects your stack