What’s Vulnerable › Vulnerabilities
CVE-2024-35234: Discourse vulnerable to stored-dom XSS via Facebook Oneboxes
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, an attacker can execute arbitrary JavaScript on users’ browsers by posting a specific URL containing maliciously crafted meta tags. This issue only affects sites with Content Security Polic (CSP) disabled. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. As a workaround, ensure CSP is enabled on the forum.
Affected products
- discourse: before 3.2.3; before 3.3.0; 3.3.0-beta1, 3.3.0-beta2 — fixed in 3.2.3, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.3, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2
- https://github.com/discourse/discourse/security/advisories/GHSA-5chg-hm8c-wc58
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2
- https://github.com/discourse/discourse/security/advisories/GHSA-5chg-hm8c-wc58
Get alerted when CVE-2024-35234 or the next vulnerability affects your stack