What’s Vulnerable › Vulnerabilities
CVE-2024-35236: Audiobookshelf Cross-Site-Scripting vulnerability via crafted ebooks
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.10.0, opening an ebook with malicious scripts inside leads to code execution inside the browsing context. Attacking a user with high privileges (upload, creation of libraries) can lead to remote code execution (RCE) in the worst case. This was tested on version 2.9.0 on Windows, but an arbitrary file write is powerful enough as is and should easily lead to RCE on Linux, too. Version 2.10.0 contains a patch for the vulnerability.
Affected products
- advplyr audiobookshelf: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf/assets/36849099/46f6dfe0-9860-4ec0-a987-b3a553f7e45d
- https://github.com/advplyr/audiobookshelf/blob/04ed4810fdfcafc2e82db536edc5870e3f937d00/client/components/readers/EpubReader.vue#L319
- https://github.com/advplyr/audiobookshelf/commit/ce7f891b9b2cb57c6644aaf96f89a8bda6307664
- https://github.com/advplyr/audiobookshelf/releases/tag/v2.10.0
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-7j99-76cj-q9pg
- https://github.com/advplyr/audiobookshelf/assets/36849099/46f6dfe0-9860-4ec0-a987-b3a553f7e45d
- https://github.com/advplyr/audiobookshelf/blob/04ed4810fdfcafc2e82db536edc5870e3f937d00/client/components/readers/EpubReader.vue#L319
- https://github.com/advplyr/audiobookshelf/commit/ce7f891b9b2cb57c6644aaf96f89a8bda6307664
- https://github.com/advplyr/audiobookshelf/releases/tag/v2.10.0
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-7j99-76cj-q9pg
Get alerted when CVE-2024-35236 or the next vulnerability affects your stack