What’s Vulnerable › Vulnerabilities

CVE-2024-35241: Composer vulnerable to command injection via malicious git branch name

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.

Affected products

How to fix

Upgrade to a fixed version: composer 2.2.24, 2.7.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-35241 or the next vulnerability affects your stack