What’s Vulnerable › Vulnerabilities

CVE-2024-35242: Composer vulnerable to command injection via malicious git/hg branch names

Description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.

Affected products

How to fix

Upgrade to a fixed version: composer 2.2.24, 2.7.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-35242 or the next vulnerability affects your stack