What’s Vulnerable › Vulnerabilities
CVE-2024-35280
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Fortinet FortiDeceptor 5.3.0, FortiDeceptor 5.2.0, FortiDeceptor 5.1 all versions, FortiDeceptor 5.0 all versions, FortiDeceptor 4.3 all versions, FortiDeceptor 4.2 all versions, FortiDeceptor 4.1 all versions, FortiDeceptor 4.0 all versions, FortiDeceptor 3.3 all versions, FortiDeceptor 3.2 all versions, FortiDeceptor 3.1 all versions, FortiDeceptor 3.0 all versions may allow an attacker to perform a reflected cross-site scripting attack in the recovery endpoints
Affected products
- Fortinet FortiDeceptor: from 3.0.0 before 5.2.1; 5.3.0 — fixed in 5.2.1
How to fix
Upgrade to a fixed version: Fortinet FortiDeceptor 5.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-35280 or the next vulnerability affects your stack