What’s Vulnerable › Vulnerabilities
CVE-2024-3548: Shortcodes Ultimate < 7.1.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Shortcodes Plugin — Shortcodes Ultimate WordPress plugin before 7.1.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- gn_themes WP Shortcodes Plugin — Shortcodes Ultimate: before 7.1.2 — fixed in 7.1.2
How to fix
Upgrade to a fixed version: gn_themes WP Shortcodes Plugin — Shortcodes Ultimate 7.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9eef8b29-2c62-4daa-ae90-467ff9be18d8/
- https://wpscan.com/vulnerability/9eef8b29-2c62-4daa-ae90-467ff9be18d8/
Get alerted when CVE-2024-3548 or the next vulnerability affects your stack