What’s Vulnerable › Vulnerabilities
CVE-2024-3553: Tutor LMS <= 2.6.2 - Missing Authorization to Unauthenticated Limited Options Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-862
Description
The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the hide_notices function in all versions up to, and including, 2.6.2. This makes it possible for unauthenticated attackers to enable user registration on sites that may have it disabled.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3076302/tutor/tags/2.7.0/classes/User.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f8d4029e-07b0-4ceb-ae6e-11a3f7416ebc?source=cve
- https://plugins.trac.wordpress.org/changeset/3076302/tutor/tags/2.7.0/classes/User.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f8d4029e-07b0-4ceb-ae6e-11a3f7416ebc?source=cve
Get alerted when CVE-2024-3553 or the next vulnerability affects your stack