What’s Vulnerable › Vulnerabilities
CVE-2024-35627
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-79
Description
tileserver-gl up to v4.4.10 was discovered to contain a cross-site scripting (XSS) vulnerability via the component /data/v3/?key.
Affected products
- Tileservergl: before 4.4.10 — fixed in 4.4.10
How to fix
Upgrade to a fixed version: Tileservergl 4.4.10. Check the vendor advisory for mitigations.
References
- https://gist.github.com/SaleSlave/e23d49e7f8eb937784d15c2c2fc34fca
- https://gist.github.com/SaleSlave/e23d49e7f8eb937784d15c2c2fc34fca
Get alerted when CVE-2024-35627 or the next vulnerability affects your stack