What’s Vulnerable › Vulnerabilities
CVE-2024-35633: WordPress Blocksy Companion plugin <= 2.0.42 - Server Side Request Forgery (SSRF) vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Creative Themes Blocksy Companion blocksy-companion.This issue affects Blocksy Companion: from n/a through <= 2.0.42.
Affected products
- creativethemeshq Blocksy Companion: before 2.0.43 — fixed in 2.0.43
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy Companion 2.0.43. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/blocksy-companion/vulnerability/wordpress-blocksy-companion-plugin-2-0-42-server-side-request-forgery-ssrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/blocksy-companion/wordpress-blocksy-companion-plugin-2-0-42-server-side-request-forgery-ssrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-35633 or the next vulnerability affects your stack