What’s Vulnerable › Vulnerabilities
CVE-2024-3565: Content Blocks (Custom Post Widget) <= 3.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via content_block Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Content Blocks (Custom Post Widget) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_block' shortcode in all versions up to, and including, 3.3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- vanderwijk Content Blocks (Custom Post Widget): before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: vanderwijk Content Blocks (Custom Post Widget) 3.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/custom-post-widget/trunk/shortcode.php#L62
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3078739%40custom-post-widget&new=3078739%40custom-post-widget&sfp_email=&sfph_mail=#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/16d8eab2-953a-46bf-a0f6-296bcea86305?source=cve
- https://plugins.trac.wordpress.org/browser/custom-post-widget/trunk/shortcode.php#L62
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3078739%40custom-post-widget&new=3078739%40custom-post-widget&sfp_email=&sfph_mail=#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/16d8eab2-953a-46bf-a0f6-296bcea86305?source=cve
Get alerted when CVE-2024-3565 or the next vulnerability affects your stack