What’s Vulnerable › Vulnerabilities
CVE-2024-35664: WordPress WPvivid Backup for MainWP plugin <= 0.9.32 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpvividplugins WPvivid Backup for MainWP wpvivid-backup-mainwp allows Reflected XSS.This issue affects WPvivid Backup for MainWP: from n/a through <= 0.9.32.
Affected products
- wpvividplugins WPvivid Backup for MainWP: before 0.9.33 — fixed in 0.9.33
How to fix
Upgrade to a fixed version: wpvividplugins WPvivid Backup for MainWP 0.9.33. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/wpvivid-backup-mainwp/vulnerability/wordpress-wpvivid-backup-for-mainwp-plugin-0-9-32-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wpvivid-backup-mainw/wordpress-wpvivid-backup-for-mainwp-plugin-0-9-32-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35664 or the next vulnerability affects your stack