What’s Vulnerable › Vulnerabilities
CVE-2024-35676: WordPress Recurring PayPal Donations plugin <= 1.7 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in wpecommerce Recurring PayPal Donations allows Stored XSS.This issue affects Recurring PayPal Donations: from n/a through 1.7.
Affected products
- wpecommerce Recurring PayPal Donations: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: wpecommerce Recurring PayPal Donations 1.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/recurring-donation/wordpress-recurring-paypal-donations-plugin-1-7-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/recurring-donation/wordpress-recurring-paypal-donations-plugin-1-7-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35676 or the next vulnerability affects your stack