What’s Vulnerable › Vulnerabilities
CVE-2024-35677: WordPress MegaMenu plugin <= 2.3.12 - Unauthenticated Local File Inclusion vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-10 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in StylemixThemes MegaMenu allows PHP Local File Inclusion.This issue affects MegaMenu: from n/a through 2.3.12.
Affected products
- StylemixThemes MegaMenu: before 2.3.13 — fixed in 2.3.13
How to fix
Upgrade to a fixed version: StylemixThemes MegaMenu 2.3.13. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/stm-megamenu/wordpress-megamenu-plugin-2-3-12-unauthenticated-local-file-inclusion-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/stm-megamenu/wordpress-megamenu-plugin-2-3-12-unauthenticated-local-file-inclusion-vulnerability?_s_id=cve
Get alerted when CVE-2024-35677 or the next vulnerability affects your stack