What’s Vulnerable › Vulnerabilities
CVE-2024-35684: WordPress ElasticPress plugin <= 5.1.1 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in 10up ElasticPress elasticpress.This issue affects ElasticPress: from n/a through <= 5.1.1.
Affected products
- 10up ElasticPress: before 5.1.2 — fixed in 5.1.2
How to fix
Upgrade to a fixed version: 10up ElasticPress 5.1.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/elasticpress/vulnerability/wordpress-elasticpress-plugin-5-1-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/elasticpress/wordpress-elasticpress-plugin-5-1-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-35684 or the next vulnerability affects your stack