What’s Vulnerable › Vulnerabilities
CVE-2024-35695: WordPress WP Docs plugin <= 2.1.3 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Fahad Mahmood WP Docs allows Stored XSS.This issue affects WP Docs: from n/a through 2.1.3.
Affected products
- fahadmahmood Wp Docs: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: fahadmahmood Wp Docs 2.1.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-docs/wordpress-wp-docs-plugin-2-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-docs/wordpress-wp-docs-plugin-2-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35695 or the next vulnerability affects your stack