What’s Vulnerable › Vulnerabilities
CVE-2024-35700: WordPress UserPro plugin <= 5.1.8 - Unauthenticated Account Takeover vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-266
Description
Incorrect Privilege Assignment vulnerability in DeluxeThemes Userpro userpro.This issue affects Userpro: from n/a through <= 5.1.8.
Affected products
- UserPro - Community and User Profile WordPress Plugin: before 5.1.9 — fixed in 5.1.9
How to fix
Upgrade to a fixed version: UserPro - Community and User Profile WordPress Plugin 5.1.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/userpro/vulnerability/wordpress-userpro-plugin-5-1-8-unauthenticated-account-takeover-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/userpro/wordpress-userpro-plugin-5-1-8-unauthenticated-account-takeover-vulnerability?_s_id=cve
Get alerted when CVE-2024-35700 or the next vulnerability affects your stack