What’s Vulnerable › Vulnerabilities
CVE-2024-35715: WordPress Bloglo and Blogvi themes affected by Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in peregrinethemes Bloglo, peregrinethemes Blogvi allows Stored XSS.This issue affects Bloglo: from n/a through 1.1.3; Blogvi: from n/a through 1.0.5.
Affected products
- Peregrine-Themes Bloglo: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: Peregrine-Themes Bloglo 1.1.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bloglo/wordpress-bloglo-theme-1-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/bloglo/wordpress-bloglo-theme-1-1-3-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35715 or the next vulnerability affects your stack