What’s Vulnerable › Vulnerabilities
CVE-2024-35719: WordPress RestroPress plugin <= 3.1.2.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in MagniGenie RestroPress allows Stored XSS.This issue affects RestroPress: from n/a through 3.1.2.1.
Affected products
- Magnigenie RestroPress: before 3.1.2.2 — fixed in 3.1.2.2
How to fix
Upgrade to a fixed version: Magnigenie RestroPress 3.1.2.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/restropress/wordpress-restropress-plugin-3-1-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/restropress/wordpress-restropress-plugin-3-1-2-1-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-35719 or the next vulnerability affects your stack